eVOLVER Wiki + Software Release 2.0.0

Ok figured it out - I’ll write a guide up on the wiki. It’s just very picky about how the file is placed there. You can scp the AppImage file over, ssh over to the pi, remove the old file (or backup using the mv command), then use mv to put the new AppImage in place, naming it evolver-electron-1.0.0.AppImage. The autostart script is looking explicitly for this filename at /users/pi/.


Hey Zack, thanks for the help but I’m still having issues. I tried the renaming strategy of the new evolver-electron-2.0.0.AppImage file to evolver-electron-1.0.0.AppImage whilst backing up the older version with mv evolver-electron-1.0.0.AppImage evolver-electron-1.0.0.AppImage-old but I’m still getting a blank, slightly lit-up screen with the following contents of the /users/pi directory:

That being said I have simply scp’d the AppImage file that I downloaded from the GitHub instead of packaging it myself with yarn; not sure if that’s the problem. I can give that a shot and report back.

Hi, I too am having this same problem. I tried packaging it myself and that didn’t fix anything. One thing worth noting is that for me the original .AppImage file is at /home/pi, not /users/pi. I don’t think this should make a difference but am unsure. I checked and I don’t have a /users directory at all.

Sorry, I wrote my original response from memory. I go between different operating systems and mix the paths up sometimes. I’ll make a more detailed post with screenshots on Monday.

Did you remove the old file (by either using mv or rm) before putting the new one in place? And did you place the file while being ssh’d on the PI (i.e. not simply by scp’ing the file)?

I think there are some weird permissions issues that depend on how the file was put in place. So if you place it (using mv) while being the pi user while ssh’d on the pi the permissions are set differently than if the file is placed via scp. I’ll dive into it more next week and do a more detailed post. Again, you can simply use the old version of the GUI on the rpi for now, functionally the new version changes nothing on the setup page, and on the new version that is the only button that appears on the pi.


I followed these, as listed on the evolver-electron github:
$ scp release/evolver-electron-1.0.0.AppImage pi@<RPI_IP>:~/evolver-electron-1.0.0.AppImage-new
$ ssh pi@<RPI_IP>
$ mv evolver-electron-1.0.0.AppImage evolver-electron-1.0.0.AppImage-old
$ mv evolver-electron-1.0.0.AppImage-new evolver-electron-1.0.0.AppImage
$ sudo reboot now

1 Like

Thanks, that’s helpful! I’ll get back to you Monday or Tuesday.

Hi All,

The following worked for me:

1. SCP File to Pi

For me, on my mac, I typed the following:

scp Downloads/evolver-electron-2.0.0.AppImage pi@your_evolver_address:

2. Change permissions of the AppImage

sudo chmod +x evolver-electron-2.0.0.AppImage

3. Change what AppImage the Pi uses to start in kiosk mode

sudo nano /etc/xdg/openbox/autostart

Scroll down and change the following lines to what version of the App you are using:

# Start Electron App in Kiosk Mode

Reboot eVOLVER.

Hope this helps! Thanks for all the feedback!



Good ole’ chmod +x :slight_smile: I’ll add this to the wiki in the installation instructions for the GUI and link it in the server update page. Thanks Brandon!

Hi, unfortunately this still didn’t fix it. After doing this and rebooting the only choice available on the raspberry pi GUI is “settings”.

For the time being, I have decided to revert everything to v1.2.1; I was also having an issue when I tried updating the server where it could no longer communicate with the arduinos.

There should only be a “SETUP” button on the most recent version. If you aren’t just seeing a black screen it’s likely working the way it’s supposed to be.

We temporarily removed “CALIBRATIONS”, as they require some additional dependencies and configurations that aren’t on the RPi image we send out by default in order to do them without the need to subsequently run a script on a connected lab desktop/laptop. We will be adding it back soon.

Hi @kawidney,

Tracked down the problem with the connection not working - I’ll put out a fix tomorrow! Thanks for helping us out!


1 Like

I updated the binary file in the release on github and pushed the changes to hotfix. This, combined with Brandon’s instructions for adding the executable flag to the file permissions, should resolve all issues. Let me know if you still have problems!

Unfortunately still not working, after having updated everything, when I reboot the server (or the machine), I stop receiving updates on OD and temp, and cannot send commands to change stir rate

Sorry it’s still not working for you. Can you log into the RPi via terminal and run the following:

sudo supervisorctl
tail -f evolver

then let that run for about a minute and post a screenshot here? Also try to set the stir while this is running.

This was after about 5 minutes. “Received COMMAND” occurred when I tried to change the stir rate. “Time to set active cals…” occurred when set the different calibrations.

Can you send a screenshot of your conf.yml file located at ~/evolver/evolver/conf.yml?

I think I left out a critical detail in my original post - you need to add this line to your conf.yml file then restart the eVOLVER:

1 Like

That did it! Thank you for all the help


Worked for me as well, thanks for documenting the awesome discussions! Just wanted to chime in and let you know that aside from only having the “Setup” button which you already mentioned, I have also lost the ‘dragging’ feature on the devices GUI. Otherwise everything works well.